Category Archives: Linux - Page 2

Gentoo Linux on a Sun Enterprise 250 Sparc

Well, there was a machine at work that was so old and unpatched that it needed to have a new OS installed on it before we could get the required software running correctly.  We contemplated a few different OS’: FreeBSD, Gentoo Linux, Solaris 9, and Solaris 10.  In the end we tried FreeBSD first.  We downloaded the latest stable release, but the system would hang trying to load the kernel.  We then tried Solaris 10. After 20 minutes into the install, we decided we would rather try Gentoo Linux.  This was the first time I’ve really dealt with installing an OS on a sparc machine, let alone linux on it.  It was a very unique feat.  In the end, I was able to get it up and running and stable!!!  I even have a software raid 1 running on all the partitions except for the boot partition.  I’m still trying to get the software raid 1 to work on the boot partition correctly, but have not figured it out yet.

ATI Mobility x1400 on Linux Working … Kinda

I ran across a post in a forum on the Gentoo Forums that pointed out a VERY dirty hack to get the ATI Mobility x1400 working correctly at the correct resolutions.  I haven’t check to see if anything else is working (3D, accelleration, etc) because all I really needed was correct 2D working at 1920×1200.  I was able to get my laptop to work now with 1920×1200 resolution which just looks great.  One issue that I’m having is that when using the console, my font is fuzzy. Fuzzy meaning the pixels around the words are constantly turning on and off in some places.  This is not the console in Xorg, but the one when you hit ALT-F1 …

The only way I was able to get the ati drivers to compile correctly was to switch from using the -mm kernel branch to the standard gentoo sources branch.  I was then able to get the ati drivers to install correctly.  After that I was able to switch a driver out with one at this website.  At that point, everything worked correctly.

Since I switched kernels, my wireless card has stopped working again.  Since I want this laptop for work, which I have a wired connection at work, I’m not too worried about it.  I’ll get it working eventually, just need to spend more time getting it to work with the non -mm kernel. 

Warning about ATI Radeon Mobility X1400 on Linux

So here’s the issue, I bought the Inspiron E1705 with the upgraded video card option, which was the ATI Radeon Mobility X1400.  I also got the upgraded monitor, so the resolution on the monitor is 1920×1200.  Looks great in my opinion.  The issues are that there is currently no support at all for the video card in linux.  You can use the vesa drivers, which will give you a resolution of 1600×1200, which really does get annoying seeing things stretched.  The open source radeon drivers do not work with this chipset, and for some reason ATI has not released any linux drivers for this video card.

I’m going to keep a lookout for solutions on getting this video card working at the correct resolution in linux.  If you are a linux user, I would recommend that you try to get an nVidia card instead of an ATI if at all possible.  nVidia has already released linux video drivers for it’s newest mobility chipsets.  If I had that option when I got this laptop, I would definitely taken that option.

E1705 Showed Up, Linux Installation Started

Well, the Dell Inspiron E1705 I bought showed up yesterday.  Only showed up two weeks before they said it was.  No compaints on this end.  Pretty nice laptop, all in all.

I’ve already started to install Gentoo Linux on the E1705.  Been taking notes what I do along the way.  With all new hardware, this is going to take a little bit to get everything working.  At this time, I have a somewhat stable system running.  I’m still trying new things constantly, so I haven’t gotten to the point to write a good guide to follow as of yet. 

For example, I have just gotten the Intel 3945ABG wireless network card to work, but to do so I’m using the mm-sources kernel tree (linux-2.6.16-rc6-mm2).  I have gotten xorg to work using the vesa drivers, but I am having issues with the ati-drivers (not sure if they will even work at this point).  I think I might stick with this kernel though since it did end up having a lot of nice things added, card reader support and a scheduler for multi-core systems.  I think by the end of this week I’ll have a nice guide up though.  I’ll put the lspci output up now though.

There is also one more issue I might need to solve first.  When trying to install my Windows XP Professional that I had got from school, I always get a blue screen of death during the installation.  Something about the pci.sys is causing trouble.  Still looking into that issue, but it was using a Windows XP Pro installation disk that did not have any service packs.

Komodo on Gentoo AMD64

I had ran into a few issues when I tried running Komodo on my desktop machine that is running an AMD64.  The install went just fine, but when I tried to run Komodo it would fail while looking for libraries.  In my particular case it was the libgtk-x11-2.0.so.0.  When I did `ldd komodo-bin`, I realized that was not the only library that was missing.  It ended up I needed to install more lib32 compat libraries.  The fix to the issue was to emerge ‘app-emulation/emul-linux-x86-gtklibs’ which fixed all my problems and allowed me to run Komodo.

Here is a list of the emul libraries that I have installed on my system in case other people are having problems:

app-emulation/emul-linux-x86-baselibs
app-emulation/emul-linux-x86-compat
app-emulation/emul-linux-x86-glibc
app-emulation/emul-linux-x86-gtklibs
app-emulation/emul-linux-x86-java
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-xlibs

I’m not saying that you will need all of these.   More than likely you will not need them all.  This is just the list of the ones that I had installed when Komodo is working. 

Added page for installing linux on Inspiron 6000

I decided it would be a lot easier if I just created a seperate page that I could keep updating on how to install Gentoo Linux on an Inspiron 6000.  This would make it easier on me to just update one place instead of just throwing the updates into seperate posts or going back and constantly changing that post.  Also divided the sections up and made it a little easier to follow alongside the gentoo documentation.  You can get to it from the Pages section on the side bar or the direct link is here.

Linux working again

So I finally have both Windows XP Pro and Gentoo Linux installed on my laptop and running correctly.  I’m currently using bios version A08 also.  The best part yet, X is working!!!  I’m pretty excited about that.  I documentated everything I did along the way and am trying to put my notes all together for an update to my original linux installation guide.

Some points to note for now are that I still had to patch the gentoo kernel source so that the cdrom worked currectly with DMA, I’m using Xorg CVS branch where I also had to apply patches to the source also, and I’m still using the ~x86 gcc version for pentium-m optimizations.  I found a lot of good information in the forums in my original thread that helped.  Expect to see a page added soon with the update to date installation instructions. 

Bad Bios Update

Well, I updated the bios from A05 to A07 on my Inspiron 6000 with some really bad results.  X has decided it’s not happy at all with the new bios.  I have even tried to use the experimental (dev) version of x along with the kernel 2.6.12 with no luck in it working yet.  This is just a warning to those.  I’m going to spend a few more hours trying to get it to work.  I might just downgrade the bios back to A05 since I wasn’t having any problems with that version.

Dell 6000, Gentoo Linux, i915, xorg update

I’ve had quite a few people ask me how I’m doing my system, since it has been a while since I published my configuration files and instructions on how to get it up. I really don’t have time to write a new updated instructions (graduating in less than week), but I have uploaded my latest xorg and conf files. Just to note that I am using Xorg version 6.8.2. I know I lot of people are using the cvs version, but I have found on all my computers when I try this that it eats up over 384 megs of RAM so I’ve decided not to go that direction.

I also change the source code of the linux code before I compile it also so that my cdrom uses the SATA drivers. In /usr/src/linux/include/linux/libata.h change:
#undef ATA_ENABLE_ATAPI /* define to enable ATAPI support */
to
#define ATA_ENABLE_ATAPI /* define to enable ATAPI support */

config-2.6.11-gentoo-r8
xorg-20050602.conf

I had started a thread a long time ago in the forums at Gentoo which now has quite a lot of information in it. I would highly recommend anyone trying to get the Inspiron 6000 working with linux to check it out. I’ve been so busy that I’ve probably missed some updates and new ways of doing things. The forum is here.

i915 and xorg cvs

I found some free time and decided that the performance of the vesa drives for the intel i915 graphics card was driving me nuts. I installed the xorg from their cvs through a crafty way of tricking portage into believing it was just reinstalling xorg 6.8.2-r1. Once this was installed, I was able to use the i810 driver in xorg (which is what then loads the correct i915). Everything worked just fine for getting it to work that way. Performance is definitely a whole lot better. Of course, there was one problem, which was that DRI can not load the module correctly even though it’s there. That will have to be something to wait to fix another day as I have exams the next two days.